Tailwind CSS on GitHub

浏览器支持

了解Tailwind浏览器支持哪些浏览器,以及如何管理供应商前缀。

从2.0版本开始,Tailwind CSS是为Chrome、Firefox、Edge和Safari的最新稳定版本设计和测试的。Tailwind CSS v2.0不支持任何版本的IE,包括ie11。

如果你需要支持IE 11,我们推荐使用Tailwind CSS v1.9,它仍然是一个非常优秀和高效的框架。

某些特性(如focus-visible)被包括在内,但并不是所有现代浏览器都本机支持。除了特性本身的文档之外,我们还直接包含了关于这些特性的polyfill。

前缀

如果你正在使用tailwindcssCLI编译你的CSS,将自动添加供应商前缀。

如果没有,我们建议你使用Autoprefixer

要使用它,请通过npm安装它:

# Using npm
npm install autoprefixer

# Using Yarn
yarn add autoprefixer

然后把它添加到你的PostCSS配置插件列表的最末尾:

module.exports = {
  plugins: [
    require('tailwindcss'),
    require('autoprefixer'),
  ]
}